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Iceberg Setup Guide 
Overview 
This document provides detailed instructions for setting up an Iceberg application on a 
machine meeting the specified requirements. Iceberg is implemented as an ASP.NET web 
application, with Microsoft SQL Server 2005 as the database platform. Many of the steps 
detailed here are standard to all web applications, and there is very little that is particular 
to Iceberg. Therefore, any experience working with ASP.NET applications, or Microsoft SQL 
Server databases will be beneficial while configuring your Iceberg installation. The basic 
steps are as follows:  

 Extract the files from the archive 
 Create the database 
 Modify the application configuration file (web.config) 
 Configure IIS to host the application as a web site or virtual directory 
 Set up the required directory access permissions  
 Test the application by logging in  

Requirements 
The following software is required to set up and run Iceberg. Although Iceberg will run on 
Windows XP with IIS installed, this should only be used for local testing and evaluation. 
You will need to use Windows Server in a production environment, as IIS on Windows XP is 
deliberately crippled to prevent production use. Also, please note that SQL Server 2005 
Express Edition is not intended for use in production environments.  

 Microsoft Windows XP or Microsoft Windows Server 2003 
 IIS 5 or greater 
 .NET Framework Version 2.0.50727 
 SQL Server 2005 (Any edition, including Express) 
 SQL Server Management Studio (Any edition, including Express) 
 Zip Archiving Utility 

 

Note: SQL Server Management Studio may be required to complete set up of the database 
on your machine; it is not required at runtime. If you use SQL Server 2005 Express, you 
may not have management studio installed, you can download SQL Server Management 
Studio Express free of charge from Microsoft’s web site.  
 
Note: The archive is distributed in the ZIP format; you will need an archiving utility 
capable of extracting ZIP archives to set up Iceberg on your machine  

Extract files 

1. Extract the files from the archive to a directory on your hard drive 

The archive contains all the files and documentation you need to start running 
Iceberg. You should place it in a recognisable location such as C:\ICEBERG so that 



 

 
Copyright © 2008 Fractis Limited. All rights Reserved. 

http://www.icebergondemand.com 

you can easily find it again. The Readme in the archive provides more details on 
the specific files..  

2. Optionally move the WebApplication folder to a different location 

This directory must be accessible to IIS and ASP.NET. Please ensure the 
appropriate permissions are available in this location. Instructions are given in this 
document to enable internet access to the directory. You may want to move it to a 
different location for security reasons.  

Create the database 
The Iceberg database is distributed as a SQL script file, which can be executed from the 
command line. The script takes several parameters to define the name of the new database 
as well as its location on disk. This step requires familiarity with windows command line 
tasks, such as navigating to specific directories and formatting arguments. Experience of 
using the command line SQLCMD tool will also be useful here. 

1. Create the database 

a) Locate the database script file 

This file, named IcebergDatabase.sql, is located in the Deploy directory, 
contained within the archive you extracted in the previous section. For 
example, if you extracted the files in the archive to a directory named 
C:\Iceberg, then the backup file will be located at the following path: 
C:\Iceberg\Deploy\IcebergDatabase.sql  

b) Open a command prompt and navigate to the Deploy 
directory, which contains the IcebergDatabase.sql file 

c) Ensure that SQLCMD is available by typing sqlcmd with no 
arguments. You may have to adjust your PATH settings to 
include the Sql Server command line tools 

d) Enter the following command on a single line:  
sqlcmd -S "[ServerName]" -i IcebergDatabase.sql -v 
DatabaseName = "[DatabaseName]" PrimaryFilePhysicalName = 
"[DatabasePhysicalPath]" PrimaryLogFilePhysicalName = 
"[LogPhysicalPath]" 

 [ServerName] is the name of the Sql Server you wish to create the 
database on, for example ‘.\SQLEXPRESS’ 

 [DatabaseName] is the name for the new database 

 [DatabasePhysicalPath] is to location on disk where the file for the 
database should be stored, for example “c:\Program Files\Microsoft 
SQL Server\MSSQL.1\MSSQL\DATA\IcebergDatabase.mdf” 

 [LogPhysicalPath] is the location on disk where the file for the log 
should be stored, for example “c:\Program Files\Microsoft SQL 
Server\MSSQL.1\MSSQL\DATA\IcebergDatabase_log.ldf” 
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e) The script will now execute and create the database 

2. Change the default user name or password 

You may optionally elect to change the user name or password that was created in 
the previous step. By default, the user is named ‘IcebergUser’ and the password is 
set to ‘i1c2e3’. For security reasons, you may want to remove this account and 
replace it with a more secure login. To create a new login and associate it with the 
Iceberg database, use the following steps 

a) Create a new login using Management Studio 

 Expand the node for the database server instance and select the 
Security folder 

 Right click the Security folder and select New > Login 

 On the General tab, enter the name for the login 

Make a note of this name, as you will need it later on  

 Select SQL Server Authentication 

 Enter a password for the login 

Make a note of this password as you will need it later on  

 Uncheck Enforce password expiration 

 Uncheck User must change password at next login 

 Press OK to create the user 

b) Map the login to the Iceberg database 

 Expand the Security folder and then expand the Logins folder 

 Right click the user you just created, and select Properties 

 Go to the User Mapping page 

 In the Users mapped to this login grid, place a check beside the 
database you created above 

The database is called Iceberg in this guide; you may have chosen a 
different name  

 In the Database role membership for list, check the following 
roles 

 db_owner 

 public 

 Press OK 

c) Delete the automatically created login 
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 Return to the Security folder you were working with at the start of 
the previous step 

 Right click the automatically generated login ‘IcebergUser’ and 
click Delete 

 Press OK to delete the login 

 Press OK in the popup message informing you that you must delete 
database users 

 Navigate to the database you created in Step 1 above, and expand 
its node 

 Expand the Security > Logins node and locate the ‘IcebergUser’ 
item 

 Right click on the ‘IcebergUser’ item and click Delete 

 Press OK to complete the process 

Configure application settings 
This section assumes that you have familiarity working with XML files, and understand the 
concept of an element, and a path to an element expressed as parent > child > 
descendant. For more information on XML in general, the W3Schools site is a good place 
to start. 

1. Locate the web.config file and open it in a text editor such as 
Notepad  

The web.config file is located in the WebApplication folder, which was created 
for you when you extracted the files above  

2. Modify the connection string 

a) You will need the following information, gathered when you 
were setting up the database 

 The name of the database server (defaults to ‘.\SQLEXPRESS’) 

 The name of the Iceberg database you created (defaults to ‘Iceberg’) 

 The login name (defaults to ‘IcebergUser’) 

 The login password (defaults to ‘i1c2e3’) 

b) Locate the connection string element with the following path 
- configuration > connectionStrings > add  

The connection string is represented as an attribute of an <add> element 
with the name 
Iceberg.Data.Properties.Settings.IcebergConnectionString 
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c) Modify the connection string to refer to the database you set 
up previously  

The connection string will be set up to use the most common settings we 
expect users to choose, therefore, the server (Data Source) will be set to 
‘.\SQLEXPRESS’, and the database (Initial Catalog) and login (User ID) 
will be set to Iceberg. Using the information retrieved during the database 
setup, you can replace these settings with the ones you specified, if they 
differ. Connection strings can vary widely, and a full discussion is beyond 
the scope of this document, consult the SQL Server documentation for 
further details.  

3. Save the file and close your text editor 

Set up the Web application 
Iceberg is implemented as an ASP.NET web application. You must publish the application 
via IIS in order to use it. The steps documented here are standard steps for setting up 
virtual directories and web sites in IIS, Iceberg has no additional requirements.  

1. Decide to set up Iceberg as a dedicated website, or as a virtual 
directory in an existing site 

If you are setting up Iceberg on a Windows XP machine, IIS restricts you from 
creating multiple web sites; therefore you must set up a virtual directory in the 
Default Web Site.  

2. Open the Internet Information Services management snap in 

You can run the IIS snap-in by clicking Start > Programs > Administrative 
Tools > Internet Services Manager.  

a) Dedicated website 

 Right click on the machine name and select New > Website 

 Click next to begin 

 Enter a name for the website in the Description field and click next 

 Enter the IP address for the site and a TCP port, you may optionally 
enter a host header 

 Click next to proceed 

 Browse to the directory you created in step one and click next 

 Ensure the Read and Run Scripts checkboxes are checked and 
leave the other boxes clear, click next to proceed 

 Click next and then finish to create the site 

b) Virtual Directory 
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 Choose a web site to create the directory in (such as the Default 
Web Site) 

 Right click on the site and select New > Virtual Directory 

 On the Welcome Page of the wizard, click next 

 Enter the name of the virtual directory in the Alias field and click 
next 

 Browse to the directory created in the first step and click next 

 Ensure the Read and Run Scripts checkboxes are checked and 
leave all the other boxes clear, click next to proceed 

 Click Finish to complete the wizard and create the virtual directory 

3. Ensure the correct ASP.NET version is selected 

You must have the .NET Framework Version 2.0.50727 installed in order to run 
Iceberg. You may also have to set up the IIS script maps using the aspnet_regiis 
tool as ASP.NET may not be registered correctly if you install IIS after installing 
ASP.NET. See the documentation for further details  

a) For web sites or virtual directories, right click and select 
Properties 

b) Go to the ASP.NET tab 

If this tab is not visible, please ensure ASP.NET has been installed and 
configured for use with IIS, see the notes above  

c) Ensure the ASP.NET version dropdown is set to 2.0.50727 

d) Press OK  

4. Note: Additional steps may be required If you have version 1.x of 
the .NET framework installed 

If you are running web sites under version 1.x of the .NET framework in IIS, you 
may have to isolate the Iceberg application. If you receive a red Server 
Application Unavailable message when you attempt to access the application, 
try these steps.  

a) For IIS 5.x 

 Right click on the web site or virtual directory and select 
properties 

 Select the Home Directory or Virtual Directory tab for websites or 
virtual directories respectively 

 Under Application Settings, set the Application Protection 
setting to High (Isolated) 



 

 
Copyright © 2008 Fractis Limited. All rights Reserved. 

http://www.icebergondemand.com 

 Press OK 

b) For IIS 6.0 

 Expand the local computer node 

 Right click the Application Pools node and select New > 
Application Pool 

 In the Application pool ID field enter a name, such as Iceberg 

 Press OK 

 Right click on the web site or virtual directory and select 
properties 

 Select the Home Directory or Virtual Directory tab for websites or 
virtual directories respectively 

 Under Application Settings set the Application Pool dropdown to 
the pool you just created 

 Press OK 

5. Set up access permissions 

a) Disable Windows XP Simple file sharing 

If you are using Windows XP, you must disable Simple file sharing to 
access security settings for a directory  

 Open My Computer 

 Go to the Tools > Folder Options on the menu bar of the My 
Computer window 

 When the Folder Options form appears, Select the View tab 

 In the Advanced Settings area, scroll to the bottom of the list 

 Ensure the Use simple file sharing (Recommended) checkbox is 
clear 

 Press OK 

b) Enabling internet access to the WebApplication directory 

If you placed the WebApplication folder in a location outside of your web 
root (by default c:\inetpub\wwwroot) then you will need to grant read 
permissions for the Internet User Guest account and the ASP.NET 
worker process account. If you see the red Server Application 
Unavailable message, and the event log entry contains an Access is 
denied message, then complete the following steps.  

 Right click on the folder you wish to grant access to and select 
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Properties 

 Select the Security tab and then click the Add button 

 In the area that appears, type the name of the ASP.NET user 
account 

If you see a Name not found popup ensure that you are using the correct 
account for your version of Windows, and that you have spelled the name 
correctly.  

 For Windows XP, type ASPNET 

 For Windows Server 2003 type IIS_WPG 

 Press OK to add an entry for the account 

 Click the Add button once more 

 In the area that appears, type the name of the Internet Guest 
User account 

The name of this account is IUSR_<machine name> where <machine 
name> is the name of the computer. If you do not know the name of the 
computer, or your computer name has changed since IIS was installed, it 
may be easier to simply view all the users available, and select the correct 
one. To do so: 

 Click the Advanced button on the Select users or groups 
form 

 When the extended form appears, click Find Now 

 This will list all the user identities available for selection. Select 
the one that begins with IUSR_ and press OK. 

 This will enter the name of the account in the preceding form, 
at which point you can continue.  

 Press OK 

c) Granting extended permissions to the ASP.NET account for 
specific application folders 

These steps tell you how to add permissions for the ASP.NET user account. 
You must complete these steps for each of the folders which require 
access, see below.  

 Right click on the folder you wish to grant access to and select 
Properties 

 Select the Security tab and then click the Add button 

 In the area that appears, type the name of the ASP.NET user 
account 

If you see a Name not found popup ensure that you are using the correct 
account for your version of Windows, and that you have spelled the name 
correctly.  

 For Windows XP, type ASPNET 

 For Windows Server 2003 type IIS_WPG 
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 Press OK to add an entry for the account 

 Ensure the entry you have just added is selected, and look to the 
Permissions area below 

 To the right of the Full Control permission, check the box in the 
Allow column  

 Press OK 

d) You must complete the steps above for three folders in the 
WebApplication directory 

 Temp 

 Documents 

 Images 

Test the installation 

1. Open the Internet Information Services management snap in 

You can run the IIS snap-in by clicking Start > Programs > Administrative 
Tools > Internet Services Manager.  

2. Navigate to the Web Site or Virtual Directory you created for the 
Iceberg web application  

3. Right click on the site or virtual directory, and click Browse 

4. The site should appear in the right hand pane 

5. Log in to Iceberg using the default built in admin account 

User name and password are both admin. You can change the admin password in 
the configuration area, and we advise you to do so  

6. You have successfully set up your Iceberg application! 


